Thursday 11th July 2019

voip.ridgehosts.com Telephone Support Offline

Offline till further notice

For support please open a ticket or email support@ridgehosts.com

Regards

Richard Shenker

update - 22/8/2019

We are working on restoring phone support and our goal is to be able to accept calls by tomorrow morning.

update 25/8/2019 We are awaiting deployment of a new server to host our voip full time.

update 26/8/2019 New server now deployed and we can now accept telephone calls. Sorry for the inconvenience